Debians sikkerhedsbulletin

DSA-2517-1 bind9 -- lammelsesangreb

Rapporteret den:
30. jul 2012
Berørte pakker:
bind9
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2012-3817.
Yderligere oplysninger:

Einar Lonn opdagede, at under visse omstændigheder, benyttede bind9, en DNS-server, cachede data før initialisering. Som følge deraf kunne en angriber udløse en assertion-fejl på servere under høj forespørgselsbelastning, som foretager DNSSEC-validering.

I den stabile distribution (squeeze), er dette problem rettet i version 1:9.7.3.dfsg-1~squeeze6.

I distributionen testing (wheezy), vil dette problem snart blive rettet.

I den ustabile distribution (sid), er dette problem rettet i version 1:9.8.1.dfsg.P1-4.2.

Vi anbefaler at du opgraderer dine bind9-pakker.