Debian セキュリティ勧告

DSA-2520-1 openoffice.org -- 複数のヒープベースのバッファオーバフロー

報告日時:
2012-08-01
影響を受けるパッケージ:
openoffice.org
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2012-2665.
詳細:

PRE-CERT の Timo Warns さんにより、オフィス業務用プログラム群 OpenOffice.org に複数のヒープベースのバッファオーバフローが発見されました。欠陥は XML マニフェスト暗号タグ解析コードにあります。 攻撃者は細工されたファイルを用いて、 アプリケーションのクラッシュや任意のコードの実行などが可能です。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 1:3.2.1-11+squeeze7 で修正されています。

openoffice.org パッケージはテスト版 (testing) と不安定版 (unstable) sid ディストリビューションでは、libreoffice に置き換えられています。

テスト版ディストリビューション (wheezy) では、この問題はバージョン 1:3.5.4-7 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 1:3.5.4-7 で修正されています。

直ぐに openoffice.org パッケージをアップグレードすることを勧めます。