Debians sikkerhedsbulletin

DSA-2527-1 php5 -- flere sårbarheder

Rapporteret den:
13. aug 2012
Berørte pakker:
php5
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2012-2688, CVE-2012-3450.
Yderligere oplysninger:

Flere sårbarheder er opdaget i webskriptsprog PHP. Projektet Common Vulnerabilities and Exposures har registreret følgende problemer:

  • CVE-2012-2688

    Et bufferoverløb i funktionen scandir() kunne føre til lammelsesangreb (denial of service) eller udførelse af vilkårlig kode.

  • CVE-2012-3450

    Man opdagede, at ikke-konsistent fortolkning af PDO-forberedte statements kunne føre til lammelsesangreb.

I den stabile distribution (squeeze), er dette problem rettet i version 5.3.3-7+squeeze14.

I den ustabile distribution (sid), er dette problem rettet i version 5.4.4-4.

Vi anbefaler at du opgraderer dine php5-pakker.