Debian セキュリティ勧告

DSA-2527-1 php5 -- 複数の脆弱性

報告日時:
2012-08-13
影響を受けるパッケージ:
php5
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2012-2688, CVE-2012-3450.
詳細:

ウェブスクリプティング言語 PHP に、複数の問題が発見されました。The Common Vulnerabilities and Exposures project は以下の問題を認識してい ます。

  • CVE-2012-2688

    scandir() 関数にバッファオーバフローがあり、サービス拒否攻撃と任意 のコードの実行とにつながる恐れがあります。

  • CVE-2012-3450

    PDO のプリペアドステートメントの一貫性のない構文解析処理がサービス 拒否攻撃につながる恐れのあることが発見されました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバー ジョン 5.3.3-7+squeeze14 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバー ジョン 5.4.4-4 で修正されています。

直ぐに php5 パッケージをアップグレードすることを勧めます。