Debian Security Advisory

DSA-2542-1 qemu-kvm -- multiple vulnerabilities

Date Reported:
08 Sep 2012
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2012-2652, CVE-2012-3515.
More information:

Multiple vulnerabilities have been discovered in KVM, a full virtualization solution on x86 hardware. The Common Vulnerabilities and Exposures project identifies the following problems:

  • CVE-2012-2652:

    The snapshot mode of QEMU (-snapshot) incorrectly handles temporary files used to store the current state, making it vulnerable to symlink attacks (including arbitrary file overwriting and guest information disclosure) due to a race condition.

  • CVE-2012-3515:

    QEMU does not properly handle VT100 escape sequences when emulating certain devices with a virtual console backend. An attacker within a guest with access to the vulnerable virtual console could overwrite memory of QEMU and escalate privileges to that of the qemu process.

For the stable distribution (squeeze), these problems have been fixed in version 0.12.5+dfsg-5+squeeze9.

For the testing distribution (wheezy), and the unstable distribution (sid), these problems will been fixed soon.

We recommend that you upgrade your qemu-kvm packages.