Debian セキュリティ勧告

DSA-2576-1 trousers -- サービス拒否

報告日時:
2012-11-23
影響を受けるパッケージ:
trousers
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 692649.
Mitre の CVE 辞書: CVE-2012-0698.
詳細:

Andy Lutomirski さんが TPM ユーザ空間デーモンである tcsd に入力の検証処理が欠けていることを発見しました。 巧妙に細工した入力によりデーモンをセグメンテーション違反でクラッシュさせ、 サービス拒否につなげられる可能性があります。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 0.3.5-2+squeeze1 で修正されています。

テスト版 (testing) ディストリビューション (wheezy) では、この問題はバージョン 0.3.9-1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、 この問題はバージョン 0.3.9-1 で修正されています。

直ちに trousers パッケージをアップグレードすることを勧めます。