Bulletin d'alerte Debian

DSA-2581-1 mysql-5.1 -- Plusieurs vulnérabilités

Date du rapport :
4 décembre 2012
Paquets concernés :
mysql-5.1
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 690778, Bogue 695001.
Dans le dictionnaire CVE du Mitre : CVE-2012-3150, CVE-2012-3158, CVE-2012-3160, CVE-2012-3163, CVE-2012-3166, CVE-2012-3167, CVE-2012-3173, CVE-2012-3177, CVE-2012-3180, CVE-2012-3197, CVE-2012-5611.
Plus de précisions :

Plusieurs problèmes ont été découverts dans le serveur de bases de données MySQL. Les vulnérabilités sont réglées en mettant à niveau MySQL vers une nouvelle version amont, 5.1.66, qui contient des modifications supplémentaires, comme des améliorations de performance et des corrections aux défauts de pertes de données. Ces modifications sont décrites dans les notes de publications de MySQL.

Pour la distribution testing (Wheezy) et la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 5.5.28+dfsg-1.

De plus, CVE-2012-5611 a été corrigée dans cette mise à jour. La vulnérabilité (découverte indépendamment par Tomas Hoger de l'équipe de réponse à la sécurité de Red Hat et king cope) est un dépassement de pile dans acl_get() lors de la vérification d'accès utilisateur à une base de données. En utilisant un nom de base de données contrefait avec attention, un utilisateur MySQL déjà identifié pourrait faire planter le serveur ou même exécuter du code arbitraire en tant qu'utilisateur système mysql.

Pour la distribution stable (Squeeze), ce problème a été corrigé dans la version 5.1.66-0+squeeze1.

Pour la distribution testing (Wheezy) et la distribution unstable (Sid), ce problème sera corrigé prochainement.

Nous vous recommandons de mettre à jour vos paquets mysql-5.1.