Bulletin d'alerte Debian

DSA-2583-1 iceweasel -- Plusieurs vulnérabilités

Date du rapport :
8 décembre 2012
Paquets concernés :
iceweasel
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le dictionnaire CVE du Mitre : CVE-2012-4201, CVE-2012-4207, CVE-2012-4216, CVE-2012-5829, CVE-2012-5842.
Plus de précisions :

Plusieurs vulnérabilités ont été découvertes dans Iceweasel, le navigateur web de Debian basé sur Firefox de Mozilla.

  • CVE-2012-5829

    Un dépassement de tampon de tas dans la fonction nsWindow::OnExposeEvent pourrait permettre aux attaquants distants d'exécuter du code arbitraire.

  • CVE-2012-5842

    Plusieurs vulnérabilités non précisées dans le moteur du navigateur pourraient permettre aux attaquants distants de provoquer un déni de service (corruption de mémoire et plantage d'application) ou éventuellement exécuter du code arbitraire.

  • CVE-2012-4207

    L'implémentation du jeu de caractères HZ-GB-2312 ne traite pas correctement un caractère ~ (tilde) à proximité d'un délimiteur de morceau. Cela permet aux attaquants distants de réaliser des attaques par script intersite (XSS) à l'aide d'un document contrefait.

  • CVE-2012-4201

    L'implémentation evalInSandbox utilise un contexte incorrect lors du traitement de code JavaScript qui définit la propriété location.href. Cela permet aux attaquants distants de réaliser des attaques par script intersite (XSS) ou de lire des fichiers arbitraires en tirant parti d'un greffon du bac à sable.

  • CVE-2012-4216

    Une vulnérabilité d'utilisation de mémoire après libération dans la fonction gfxFont::GetFontEntry permet aux attaquants distants d'exécuter du code arbitraire ou de provoquer un déni de service (corruption de mémoire de tas) par des moyens non précisés.

Pour la distribution stable (Squeeze), ces problèmes ont été corrigés dans la version 3.5.16-20.

Pour la distribution testing (Wheezy), ces problèmes ont été corrigés dans la version 10.0.11esr-1.

Pour la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 10.0.11esr-1.

Nous vous recommandons de mettre à jour vos paquets iceweasel.