Debian セキュリティ勧告

DSA-2597-1 rails -- 入力検証の誤り

報告日時:
2013-01-04
影響を受けるパッケージ:
rails
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2012-6496, CVE-2012-6497.
詳細:

Phenoelit の joernchen さんが、ウェブアプリケーション開発向けの MVC ruby ベースのフレームワーク rails がユーザにより提供された find_by_* メソッドへの入力を適切に扱っていないことを発見しました。ruby on rails アプリケーションがこのメソッドをどのように利用しているのかによりますが、攻撃者が SQL インジェクション攻撃を実行することにより、例えば Authlogic が利用されている場合はセッションの秘密トークンを知っていれば認証の迂回を許します。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 2.3.5-1.2+squeeze4 で修正されています。

テスト版 (testing) ディストリビューション (wheezy) では、この問題は近く修正予定です。

不安定版 (unstable) ディストリビューション (sid) では、この問題は ruby-activerecord-2.3 のバージョン 2.3.14-3 で修正されています。

直ちに rails/ruby-activerecord-2.3 パッケージをアップグレードすることを勧めます。