Рекомендация Debian по безопасности

DSA-2598-1 weechat -- несколько уязвимостей

Дата сообщения:
05.01.2013
Затронутые пакеты:
weechat
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2011-1428, CVE-2012-5534.
Более подробная информация:

В WeeChat, быстром легком и расширяемом чат-клиенте, были обнаружены две проблемы безопасности:

  • CVE-2011-1428

    Сертификаты X.509 проверялись неправильно.

  • CVE-2012-5534

    Функция hook_process в API плагинов позволяла выполнять произвольные команды оболочки.

В стабильном выпуске (squeeze) эти проблемы были исправлены в версии 0.3.2-1+squeeze1.

В тестируемом выпуске (wheezy) эти проблемы были исправлены в версии 0.3.8-1+deb7u1.

В нестабильном выпуске (sid) эти проблемы были исправлены в версии 0.3.9.2-1.

Рекомендуется обновить пакеты weechat.