Рекомендация Debian по безопасности

DSA-2601-1 gnupg, gnupg2 -- отсутствие очистки ввода

Дата сообщения:
06.01.2013
Затронутые пакеты:
gnupg, gnupg2
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 697108, Ошибка 697251.
В каталоге Mitre CVE: CVE-2012-6085.
Более подробная информация:

Кабэ Срирам обнаружил, что GnuPG, GNU Privacy Guard, недостаточно очищает публичные ключи при их импорте, что может приводить к повреждению памяти и связки ключей.

Данная проблема действительна и для версии один из пакета gnupg, и для версии два из пакета gnupg2.

В стабильном выпуске (squeeze) эта проблема была исправлена в версии 1.4.10-4+squeeze1 пакета gnupg и в версии 2.0.14-2+squeeze1 пакета gnupg2.

В тестируемом (wheezy) и нестабильном (sid) выпусках эта проблема была исправлена в версии 1.4.12-7 пакета gnupg и в версии 2.0.19-2 пакета gnupg2.

Рекомендуется обновить пакеты gnupg и/или gnupg2.