Debian Security Advisory

DSA-2604-1 rails -- insufficient input validation

Date Reported:
09 Jan 2013
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 697722.
In Mitre's CVE dictionary: CVE-2013-0156.
More information:

It was discovered that Rails, the Ruby web application development framework, performed insufficient validation on input parameters, allowing unintended type conversions. An attacker may use this to bypass authentication systems, inject arbitrary SQL, inject and execute arbitrary code, or perform a DoS attack on the application.

For the stable distribution (squeeze), this problem has been fixed in version 2.3.5-1.2+squeeze4.1.

For the testing distribution (wheezy) and unstable distribution (sid), this problem will be fixed soon.

We recommend that you upgrade your rails packages.