Debian セキュリティ勧告

DSA-2604-1 rails -- 入力の不十分な検証

報告日時:
2013-01-09
影響を受けるパッケージ:
rails
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 697722.
Mitre の CVE 辞書: CVE-2013-0156.
詳細:

Ruby ウェブアプリケーション開発フレームワーク Rails が入力パラメータの検証を十分に行っていないことが発見されました。 意図しない型変換を許します。 攻撃者はこれによりアプリケーション上で認証システムの迂回や任意の SQL 差し込み、任意のコードの差し込みや実行、DoS 攻撃が可能性となります

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 2.3.5-1.2+squeeze4.1 で修正されています。

テスト版 (testing) ディストリビューション (wheezy) および不安定版 (unstable) ディストリビューション (sid) では、この問題は近く修正予定です。

直ちに rails パッケージをアップグレードすることを勧めます。