Debian Security Advisory

DSA-2613-1 rails -- insufficient input validation

Date Reported:
29 Jan 2013
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 699226.
In Mitre's CVE dictionary: CVE-2013-0333.
More information:

Lawrence Pit discovered that Ruby on Rails, a web development framework, is vulnerable to a flaw in the parsing of JSON to YAML. Using a specially crafted payload attackers can trick the backend into decoding a subset of YAML.

The vulnerability has been addressed by removing the YAML backend and adding the OkJson backend.

For the stable distribution (squeeze), this problem has been fixed in version 2.3.5-1.2+squeeze6.

For the testing distribution (wheezy), this problem will be fixed soon.

For the unstable distribution (sid), this problem has been fixed in version 2.3.14-6 of the ruby-activesupport-2.3 package.

The 3.2 version of rails as found in Debian wheezy and sid is not affected by the problem.

We recommend that you upgrade your rails packages.