Säkerhetsbulletin från Debian

DSA-2615-1 libupnp4 -- flera sårbarheter

Rapporterat den:
2013-02-01
Berörda paket:
libupnp4
Sårbara:
Ja
Referenser i säkerhetsdatabaser:
I Debians felrapporteringssystem: Fel 699459.
I Mitres CVE-förteckning: CVE-2012-5958, CVE-2012-5959, CVE-2012-5960, CVE-2012-5961, CVE-2012-5962, CVE-2012-5963, CVE-2012-5964, CVE-2012-5965.
Ytterligare information:

Flera stack-baserade buffertspill upptäcktes i libupnp4, ett bibliotek som används för hantering av det Universella Plug och Play-protokollet. HD Moore från Rapid7 upptäckte att SSDP-förfrågningar inte hanteras korrekt av funktionen unique_service_name().

En angripare kunde generera ett buffertspill genom försiktigt skapade SSDP-förfrågningar till en demon byggd på libupnp4, och genom detta skriva över stacken, vilket leder till att demonen kraschar vilket möjliggör exekvering av fjärrkod.

För den stabila utgåvan (Squeeze) har dessa problem rättats i version 1.8.0~svn20100507-1+squeeze1.

För uttestningsutgåvan (Wheezy) har dessa problem rättats i version 1.8.0~svn20100507-1.2.

För den instabila utgåvan (Sid) har dessa problem rättats i version 1.8.0~svn20100507-1.2.

Vi rekommenderar att ni uppgraderar era libupnp4-paket.