Debian セキュリティ勧告

DSA-2624-1 ffmpeg -- 複数の脆弱性

報告日時:
2013-02-16
影響を受けるパッケージ:
ffmpeg
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2012-0858, CVE-2012-2777, CVE-2012-2783, CVE-2012-2784, CVE-2012-2788, CVE-2012-2801, CVE-2012-2803.
詳細:

複数の欠陥が、マルチメディアプレーヤ、サーバ、エンコーダ FFmpeg に発見されました。Shorten、Chinese AVS ビデオ、VP5、VP6、AVI、AVS、MPEG-1/2 ファイルのデコード/分離処理に入力検証の欠落が複数あり、 任意のコードの実行につながる可能性があります。

この問題の大部分は Mateusz Jurczyk さんと Gynvael Coldwind さんにより発見されました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 4:0.5.10-1 で修正されています。

テスト版 (testing) ディストリビューション (wheezy) および不安定版 (unstable) ディストリビューション (sid) では、この問題は libav ソースパッケージのバージョン 6:0.8.5-1 で修正されています。

直ちに ffmpeg パッケージをアップグレードすることを勧めます。