Debian セキュリティ勧告

DSA-2630-1 postgresql-8.4 -- プログラミングの誤り

報告日時:
2013-02-20
影響を受けるパッケージ:
postgresql-8.4
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2013-0255.
詳細:

Sumit Soni さんが、オブジェクト関係データベース PostgreSQL の内部関数が不正な引数を付けて呼び出された場合、 強制的にクラッシュしサービス拒否となることを発見しました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 8.4.16-0squeeze1 で修正されています。

テスト版 (testing) ディストリビューション (wheezy) では、この問題はバージョン 8.4.16-1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 8.4.16-1 で修正されています。

直ちに postgresql-8.4 パッケージをアップグレードすることを勧めます。