Debian Security Advisory

DSA-2641-2 perl -- rehashing flaw

Date Reported:
20 Mar 2013
Affected Packages:
perl, libapache2-mod-perl2
Security database references:
In the Debian bugtracking system: Bug 702296, Bug 702821.
In Mitre's CVE dictionary: CVE-2013-1667.
More information:

Yves Orton discovered a flaw in the rehashing code of Perl. This flaw could be exploited to carry out a denial of service attack against code that uses arbitrary user input as hash keys. Specifically an attacker could create a set of keys of a hash causing a denial of service via memory exhaustion.

For the stable distribution (squeeze), this problem has been fixed in version 5.10.1-17squeeze6 of perl and version 2.0.4-7+squeeze1 of libapache2-mod-perl2.

For the testing distribution (wheezy), and the unstable distribution (sid), this problem has been fixed in version 5.14.2-19 of perl and version 2.0.7-3 of libapache2-mod-perl2.

We recommend that you upgrade your perl and libapache2-mod-perl2 packages.