Debian Security Advisory

DSA-2655-1 rails -- several vulnerabilities

Date Reported:
28 Mar 2013
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2011-2932, CVE-2012-3464, CVE-2012-3465, CVE-2013-1854, CVE-2013-1855, CVE-2013-1857.
More information:

Several cross-site-scripting and denial of service vulnerabilities were discovered in Ruby on Rails, a Ruby framework for web application development.

For the stable distribution (squeeze), these problems have been fixed in version 2.3.5-1.2+squeeze8.

For the testing distribution (wheezy) and the unstable distribution (sid), these problems have been fixed in the version 3.2.6-5 of ruby-activerecord-3.2, version 2.3.14-6 of ruby-activerecord-2.3, version 2.3.14-7 of ruby-activesupport-2.3, version 3.2.6-6 of ruby-actionpack-3.2 and in version 2.3.14-5 of ruby-actionpack-2.3.

We recommend that you upgrade your rails packages.