Debian セキュリティ勧告

DSA-2655-1 rails -- 複数の脆弱性

報告日時:
2013-03-28
影響を受けるパッケージ:
rails
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2011-2932, CVE-2012-3464, CVE-2012-3465, CVE-2013-1854, CVE-2013-1855, CVE-2013-1857.
詳細:

クロスサイトスクリプティングおよびサービス拒否の脆弱性が複数、 ウェブアプリケーション開発用の Ruby フレームワーク Ruby on Rails に発見されました。

安定版 (stable) ディストリビューション (squeeze) では、この問題はバージョン 2.3.5-1.2+squeeze8 で修正されています。

テスト版 (testing) ディストリビューション (wheezy) および不安定版 (unstable) ディストリビューション (sid) では、この問題は ruby-activerecord-3.2 のバージョン 3.2.6-5、ruby-activerecord-2.3 のバージョン 2.3.14-6、ruby-activesupport-2.3 のバージョン 2.3.14-7、ruby-actionpack-3.2 のバージョン 3.2.6-6、ruby-actionpack-2.3 のバージョン 2.3.14-5 で修正されています。

直ちに rails パッケージをアップグレードすることを勧めます。