Debian Security Advisory

DSA-2657-1 postgresql-8.4 -- guessable random numbers

Date Reported:
04 Apr 2013
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2013-1900.
More information:

A vulnerability was discovered in PostgreSQL database server. Random numbers generated by contrib/pgcrypto functions may be easy for another database user to guess.

For the stable distribution (squeeze), this problem has been fixed in version 8.4.17-0squeeze1.

For the testing (wheezy) and unstable distribution (sid), postgresql-8.4 packages have been removed; in those, this problem has been fixed in postgresql-9.1 9.1.9-0wheezy1 (wheezy), and 9.1.9-1 (sid) respectively.

Note: postgresql-8.4 in Squeeze is not affected by CVE-2013-1899 (database files corruption) and CVE-2013-1901 (unprivileged user can interfere with in-progress backups).

We recommend that you upgrade your postgresql-8.4 packages.