Рекомендация Debian по безопасности

DSA-2674-1 libxv -- несколько уязвимостей

Дата сообщения:
23.05.2013
Затронутые пакеты:
libxv
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2013-1989, CVE-2013-2066.
Более подробная информация:

Илья ван Шпрундель из IOActive обнаружил несколько проблем безопасности в различных компонентах графического стека X.org и связанных с ним библиотеках: различные переполнения целых чисел, ошибки обработки знака при преобразовании целых чисел, переполнения буфера, повреждение памяти и отсутствие очистки ввода могут приводить к повышению привилегий или отказу в обслуживании.

В предыдущем стабильном выпуске (squeeze) эти проблемы были исправлены в версии 2:1.0.5-1+squeeze1.

В стабильном выпуске (wheezy) эти проблемы были исправлены в версии 2:1.0.7-1+deb7u1.

В нестабильном выпуске (sid) эти проблемы были исправлены в версии 2:1.0.7-1+deb7u1.

Рекомендуется обновить пакеты libxv.