Debians sikkerhedsbulletin

DSA-2677-1 libxrender -- flere sårbarheder

Rapporteret den:
23. maj 2013
Berørte pakker:
libxrender
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2013-1987.
Yderligere oplysninger:

Ilja van Sprundel fra IOActive opdagede sikkerhedsproblemer i flere komponenter i X.org's grafikstak og relaterede biblioteker: Forskellige heltalsoverløb, fortegnshåndteringsfejl ved heltalskonverteringer, bufferoverløb, hukommelseskorruption og manglende fornuftighedskontrol af inddata kunne føre til rettighedsforøgelse eller lammelsesangreb (denial of service).

I den gamle stabile distribution (squeeze), er dette problem rettet i version 1:0.9.6-1+squeeze1.

I den stabile distribution (wheezy), er dette problem rettet i version 1:0.9.7-1+deb7u1.

I den ustabile distribution (sid), er dette problem rettet i version 1:0.9.7-1+deb7u1.

Vi anbefaler at du opgraderer dine libxrender-pakker.