Рекомендация Debian по безопасности

DSA-2677-1 libxrender -- несколько уязвимостей

Дата сообщения:
23.05.2013
Затронутые пакеты:
libxrender
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2013-1987.
Более подробная информация:

Илья ван Шпрундель из IOActive обнаружил несколько проблем безопасности в различных компонентах графического стека X.org и связанных с ним библиотеках: различные переполнения целых чисел, ошибки обработки знака при преобразовании целых чисел, переполнения буфера, повреждение памяти и отсутствие очистки ввода могут приводить к повышению привилегий или отказу в обслуживании.

В предыдущем стабильном выпуске (squeeze) эта проблема была исправлена в версии 1:0.9.6-1+squeeze1.

В стабильном выпуске (wheezy) эта проблема была исправлена в версии 1:0.9.7-1+deb7u1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 1:0.9.7-1+deb7u1.

Рекомендуется обновить пакеты libxrender.