Рекомендация Debian по безопасности

DSA-2681-1 libxcursor -- несколько узявимостей

Дата сообщения:
23.05.2013
Затронутые пакеты:
libxcursor
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2013-2003.
Более подробная информация:

Илья ван Шпрундель из IOActive обнаружил несколько проблем безопасности в различных компонентах графического стека X.org и связанных с ним библиотеках: различные переполнения целых чисел, ошибки обработки знака при преобразовании целых чисел, переполнения буфера, повреждение памяти и отсутствие очистки ввода могут приводить к повышению привилегий или отказу в обслуживании.

В предыдущем стабильном выпуске (squeeze) эта проблема была исправлена в версии 1:1.1.10-2+squeeze1.

В стабильном выпуске (wheezy) эта проблема была исправлена в версии 1:1.1.13-1+deb7u1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 1:1.1.13-1+deb7u1.

Рекомендуется обновить пакеты libxcursor.