Debians sikkerhedsbulletin

DSA-2683-1 libxi -- flere sårbarheder

Rapporteret den:
23. maj 2013
Berørte pakker:
libxi
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2013-1984, CVE-2013-1995, CVE-2013-1998.
Yderligere oplysninger:

Ilja van Sprundel fra IOActive opdagede sikkerhedsproblemer i flere komponenter i X.org's grafikstak og relaterede biblioteker: Forskellige heltalsoverløb, fortegnshåndteringsfejl ved heltalskonverteringer, bufferoverløb, hukommelseskorruption og manglende fornuftighedskontrol af inddata kunne føre til rettighedsforøgelse eller lammelsesangreb (denial of service).

I den gamle stabile distribution (squeeze), er disse problemer rettet i version 2:1.3-8.

I den stabile distribution (wheezy), er disse problemer rettet i version 2:1.6.1-1+deb7u1.

I den ustabile distribution (sid), er disse problemer rettet i version 2:1.6.1-1+deb7u1.

Vi anbefaler at du opgraderer dine libxi-pakker.