Рекомендация Debian по безопасности

DSA-2684-1 libxrandr -- несколько уязвимостей

Дата сообщения:
23.05.2013
Затронутые пакеты:
libxrandr
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2013-1986.
Более подробная информация:

Илья ван Шпрундель из IOActive обнаружил несколько проблем безопасности в различных компонентах графического стека X.org и связанных с ним библиотеках: различные переполнения целых чисел, ошибки обработки знака при преобразовании целых чисел, переполнения буфера, повреждение памяти и отсутствие очистки ввода могут приводить к повышению привилегий или отказу в обслуживании.

В предыдущем стабильном выпуске (squeeze) эта проблема была исправлена в версии 2:1.3.0-3+squeeze1.

В стабильном выпуске (wheezy) эта проблема была исправлена в версии 2:1.3.2-2+deb7u1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 2:1.3.2-2+deb7u1.

Рекомендуется обновить пакеты libxrandr.