Debians sikkerhedsbulletin

DSA-2697-1 gnutls26 -- arraylæsning uden for grænserne

Rapporteret den:
29. maj 2013
Berørte pakker:
gnutls26
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 709301.
I Mitres CVE-ordbog: CVE-2013-2116.
Yderligere oplysninger:

Man opdagede at en ondsindet klient kunne få en GNUTLS-server til at gå ned, og omvendt, ved at sende TLS-poster krypteret med en blokcipher, der indeholder ugyldig padding.

Den gamle stabile distribution (squeeze) er ikke påvirket, da den sikkerhedsopdateringer som medførte sårbarheden, ikke blev udført dér.

I den stabile distribution (wheezy), er dette problem rettet i version 2.12.20-7.

I den ustabile distribution (sid), er dette problem rettet i version 2.12.23-5.

Vi anbefaler at du opgraderer dine gnutls26-pakker.