Debian セキュリティ勧告

DSA-2713-1 curl -- ヒープオーバーフロー

報告日時:
2013-06-24
影響を受けるパッケージ:
curl
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2013-2174.
詳細:

Timo Sirainen さんが、URL 転送ライブラリ cURL が curl_easy_unescape 関数での入力データ確認が不正であるために ヒープオーバーフロー脆弱性を起こしやすいことを発見しました。

curl コマンドラインツールは curl_easy_unescape 関数を利用しないためこの問題による影響はありません。

旧安定版 (oldstable) ディストリビューション (squeeze) では、この問題はバージョン 7.21.0-2.1+squeeze4 で修正されています。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 7.26.0-1+wheezy3 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 7.31.0-1 で修正されています。

直ちに curl パッケージをアップグレードすることを勧めます。