Debian Security Advisory

DSA-2718-1 wordpress -- several vulnerabilities

Date Reported:
01 Jul 2013
Affected Packages:
Security database references:
In the Debian bugtracking system: Bug 713947.
In Mitre's CVE dictionary: CVE-2013-2173, CVE-2013-2199, CVE-2013-2200, CVE-2013-2201, CVE-2013-2202, CVE-2013-2203, CVE-2013-2204, CVE-2013-2205.
More information:

Several vulnerabilities were identified in WordPress, a web blogging tool. As the CVEs were allocated from releases announcements and specific fixes are usually not identified, it has been decided to upgrade the wordpress package to the latest upstream version instead of backporting the patches.

This means extra care should be taken when upgrading, especially when using third-party plugins or themes, since compatibility may have been impacted along the way. We recommend that users check their install before doing the upgrade.

  • CVE-2013-2173

    A denial of service was found in the way WordPress performs hash computation when checking password for protected posts. An attacker supplying carefully crafted input as a password could make the platform use excessive CPU usage.

  • CVE-2013-2199

    Multiple server-side requests forgery (SSRF) vulnerabilities were found in the HTTP API. This is related to CVE-2013-0235, which was specific to SSRF in pingback requests and was fixed in 3.5.1.

  • CVE-2013-2200

    Inadequate checking of a user's capabilities could lead to a privilege escalation, enabling them to publish posts when their user role should not allow for it and to assign posts to other authors.

  • CVE-2013-2201

    Multiple cross-side scripting (XSS) vulnerabilities due to badly escaped input were found in the media files and plugins upload forms.

  • CVE-2013-2202

    XML External Entity Injection (XXE) vulnerability via oEmbed responses.

  • CVE-2013-2203

    A Full path disclosure (FPD) was found in the file upload mechanism. If the upload directory is not writable, the error message returned includes the full directory path.

  • CVE-2013-2204

    Content spoofing via Flash applet in the embedded tinyMCE media plugin.

  • CVE-2013-2205

    Cross-domain XSS in the embedded SWFupload uploader.

For the oldstable distribution (squeeze), these problems have been fixed in version 3.5.2+dfsg-1~deb6u1.

For the stable distribution (wheezy), these problems have been fixed in version 3.5.2+dfsg-1~deb7u1.

For the testing distribution (jessie), these problems have been fixed in version 3.5.2+dfsg-1.

For the unstable distribution (sid), these problems have been fixed in version 3.5.2+dfsg-1.

We recommend that you upgrade your wordpress packages.