Debian セキュリティ勧告

DSA-2726-1 php-radius -- バッファオーバーフロー

報告日時:
2013-07-25
影響を受けるパッケージ:
php-radius
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 714362.
Mitre の CVE 辞書: CVE-2013-2220.
詳細:

バッファオーバーフローが PHP の Radius 拡張に発見されました。ベンダー固有の属性を処理する関数が、 与えられた属性の長さが常に有効なものだと仮定していました。 攻撃者がこの仮定を利用してバッファオーバーフローを引き起こすことが可能です。

旧安定版 (oldstable) ディストリビューション (squeeze) では、この問題はバージョン 1.2.5-2+squeeze1 で修正されています。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 1.2.5-2.3+deb7u1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 1.2.5-2.4 で修正されています。

直ちに php-radius パッケージをアップグレードすることを勧めます。