Рекомендация Debian по безопасности

DSA-2738-1 ruby1.9.1 -- несколько уязвимостей

Дата сообщения:
18.08.2013
Затронутые пакеты:
ruby1.9.1
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 702525, Ошибка 714543.
В каталоге Mitre CVE: CVE-2013-1821, CVE-2013-4073.
Более подробная информация:

В интерпретаторе языка Ruby были обнаружены несколько уязвимостей, которые могут приводить к отказу в обслуживании и другим проблемам безопасности. Проект Common Vulnerabilities and Exposures определяет следующие проблемы:

  • CVE-2013-1821

    Бен Мёрфи обнаружил, что неограниченное расширение записи в REXML может приводить к отказу в обслуживании в связи с потреблением всей памяти узла.

  • CVE-2013-4073

    Уильям (B.J.) Сноу Орвис обнаружил уязвимость в проверке имени узла в клиенте SSL для Ruby, благодаря которой атакующие могут проводить атаку по схеме человек-в-середине для обмана серверов SSL с помощью корректных сертификатов, выданных доверенным органом.

В предыдущем стабильном выпуске (squeeze) эти проблемы были исправлены в версии 1.9.2.0-2+deb6u1.

В стабильном выпуске (wheezy) эти проблемы были исправлены в версии 1.9.3.194-8.1+deb7u1.

В нестабильном выпуске (sid) эти проблемы были исправлены в версии 1.9.3.194-8.2.

Мы рекомендуем вам обновить ваши пакеты ruby1.9.1.