Debians sikkerhedsbulletin

DSA-2742-1 php5 -- fortolkningskonflikt

Rapporteret den:
26. aug 2013
Berørte pakker:
php5
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 719765.
I Mitres CVE-ordbog: CVE-2013-4248.
Yderligere oplysninger:

Man opdagede at PHP, et skriptsprog der er anvendeligt til alle formål og som benyttes i udstrakt grad til webapplikationsudvikling, ikke på korrekt vis behandlede indlejrede NUL-tegn i subjectAltName-udvidelsen i X.509-certifikater. Afhængigt af applikationen, og med utilstrækkelige CA-niveaukontroller, kunne det udnyttes til at udgive sig for at være andre brugere.

I den gamle stabile distribution (squeeze), er dette problem rettet i version 5.3.3-7+squeeze17.

I den stabile distribution (wheezy), er dette problem rettet i version 5.4.4-14+deb7u4.

I den ustabile distribution (sid), er dette problem rettet i version 5.5.3+dfsg-1.

Vi anbefaler at du opgraderer dine php5-pakker.