Debians sikkerhedsbulletin

DSA-2754-1 exactimage -- lammelsesangreb

Rapporteret den:
10. sep 2013
Berørte pakker:
exactimage
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Mitres CVE-ordbog: CVE-2013-1441.
Yderligere oplysninger:

Man opdagede at exactimage, et hurtigt billedbehandlingsbibliotek, ikke på korrekt vis håndterede fejlsituationer i forbindelse med den indlejrede version af dcraw. Det kunne medføre et nedbrud eller andet i en applikation, som anvender biblioteket, på grund af en uinitialiseret variabel, som overføres til longjmp.

Det er et andet problem, end CVE-2013-1438/DSA-2748-1.

I den gamle stabile distribution (squeeze), er dette problem rettet i version 0.8.1-3+deb6u3.

I den stabile distribution (wheezy), er dette problem rettet i version 0.8.5-5+deb7u3.

I distributionen testing (jessie) og i den ustabile distribution (sid), er dette problem rettet i version 0.8.9-2.

Vi anbefaler at du opgraderer dine exactimage-pakker.