Debian セキュリティ勧告

DSA-2787-1 roundcube -- 設計上の誤り

報告日時:
2013-10-27
影響を受けるパッケージ:
roundcube
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 727668.
Mitre の CVE 辞書: CVE-2013-6172.
詳細:

roundcube、スキンを使える AJAX ベースの IMAP サーバ用ウェブメールシステムが設定保存時に steps/utils/save_pref.inc の _session パラメータを適切にサニタイズしていないことが発見されました。 この脆弱性を悪用して設定を上書きし、以後ランダムファイルアクセスや SQL クエリー操作、さらにはコードの実行までを許す可能性があります。

旧安定版 (oldstable) ディストリビューション (squeeze) の roundcube にはこの問題による影響はありません。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 0.7.2-9+deb7u1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) ではこの問題は近く修正予定です。

直ちに roundcube パッケージをアップグレードすることを勧めます。