Debians sikkerhedsbulletin

DSA-2803-1 quagga -- flere sårbarheder

Rapporteret den:
26. nov 2013
Berørte pakker:
quagga
Sårbar:
Ja
Referencer i sikkerhedsdatabaser:
I Debians fejlsporingssystem: Fejl 730513, Fejl 726724.
I Mitres CVE-ordbog: CVE-2013-2236, CVE-2013-6051.
Yderligere oplysninger:

Flere sårbarheder blev opdaget i Quagga, en routingdæmon til BGP/OSPF/RIP:

  • CVE-2013-2236

    Et bufferoverløb blev fundet i OSPF API-serveren (eksport af LSDB'en og muliggørelse af annoncering af Opaque-LSA'er).

  • CVE-2013-6051

    Man kunne få bgpd til at gå ned gennem BGP-opdateringer. Det påvirker kun Wheezy/stable.

I den gamle stabile distribution (squeeze), er disse problemer rettet i version 0.99.20.1-0+squeeze5.

I den stabile distribution (wheezy), er disse problemer rettet i version 0.99.22.4-1+wheezy1.

I den ustabile distribution (sid), er disse problemer rettet i version 0.99.22.4-1.

Vi anbefaler at du opgraderer dine quagga-pakker.