Рекомендация Debian по безопасности

DSA-2803-1 quagga -- несколько уязвимостей

Дата сообщения:
26.11.2013
Затронутые пакеты:
quagga
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 730513, Ошибка 726724.
В каталоге Mitre CVE: CVE-2013-2236, CVE-2013-6051.
Более подробная информация:

В Quagga, службе маршрутизации BGP/OSPF/RIP, были обнаружены множественные уязвимости:

  • CVE-2013-2236

    В OSPF API-server было обнаружено переполнение буфера (экспортирование LSDB и разрешение анонсирования Opaque-LSA).

  • CVE-2013-6051

    bgpd может завершаться аварийно при обновлениях BGP. Этой проблеме подвержен только выпуск Wheezy/stable.

В предыдущем стабильном выпуске (squeeze) эти проблемы были исправлены в версии 0.99.20.1-0+squeeze5.

В стабильном выпуске (wheezy) эти проблемы исправлены в версии 0.99.22.4-1+wheezy1.

В нестабильном выпуске (sid) эти проблемы исправлены в версии 0.99.22.4-1.

Мы рекомендуем обновить пакеты quagga.