Debian セキュリティ勧告

DSA-2810-1 ruby1.9.1 -- ヒープオーバーフロー

報告日時:
2013-12-04
影響を受けるパッケージ:
ruby1.9.1
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 730178.
Mitre の CVE 辞書: CVE-2013-4164.
詳細:

Charlie Somerville さんが、Ruby が浮動小数の変換処理を誤っていることを発見しました。Ruby を利用しているアプリケーションが、 信頼していない入力文字列を受け付けて浮動小数に変換する場合に、 こういった入力を提供できる攻撃者がアプリケーションのクラッシュや、 潜在的にはそのアプリケーションの権限で 任意のコードの実行を引き起こすことが可能です。

旧安定版 (oldstable) ディストリビューション (squeeze) では、この問題はバージョン 1.9.2.0-2+deb6u2 で修正されています。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 1.9.3.194-8.1+deb7u2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 1.9.3.484-1 で修正されています。

直ちに ruby1.9.1 パッケージをアップグレードすることを勧めます。