Bulletin d'alerte Debian

DLA-39-1 gpgme1.0 -- Mise à jour de sécurité pour LTS

Date du rapport :
20 août 2014
Paquets concernés :
gpgme1.0
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 756651.
Dans le dictionnaire CVE du Mitre : CVE-2014-3564.
Plus de précisions :

Tomáš Trnka a découvert un dépassement de tas dans la gestion d'état gpgsm de GPGME, une bibliothèque conçue pour faciliter l'accès des applications à GnuPG. Un attaquant pourrait utiliser ce problème pour provoquer le plantage (déni de service) d'une application utilisant GPGME ou éventuellement pour exécuter du code arbitraire.

Pour Debian 6 Squeeze, ces problèmes ont été corrigés dans la version 1.2.0-1.2+deb6u1 de gpgme1.0.