Debian Security Advisory

DSA-2851-1 drupal6 -- impersonation

Date Reported:
02 Feb 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-1475.
More information:

Christian Mainka and Vladislav Mladenov reported a vulnerability in the OpenID module of Drupal, a fully-featured content management framework. A malicious user could exploit this flaw to log in as other users on the site, including administrators, and hijack their accounts.

These fixes require extra updates to the database which can be done from the administration pages.

For the oldstable distribution (squeeze), this problem has been fixed in version 6.30-1.

We recommend that you upgrade your drupal6 packages.