Debian セキュリティ勧告

DSA-2856-1 libcommons-fileupload-java -- サービス拒否

報告日時:
2014-02-07
影響を受けるパッケージ:
libcommons-fileupload-java
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2014-0050.
詳細:

Java 向けの Apache Commons FileUpload パッケージが、Content-Type を細工したマルチパートのリクエストを処理する際に無限ループに陥る 可能性があることが発見されました。結果としてサービス拒否の状況につながります。

旧安定版 (oldstable) ディストリビューション (squeeze) では、この問題はバージョン 1.2.2-1+deb6u2 で修正されています。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 1.2.2-1+deb7u2 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 1.3.1-1 で修正されています。

直ちに libcommons-fileupload-java パッケージをアップグレードすることを勧めます。