Debian セキュリティ勧告

DSA-2866-1 gnutls26 -- 証明書検証の欠陥

報告日時:
2014-02-22
影響を受けるパッケージ:
gnutls26
危険性:
あり
参考セキュリティデータベース:
Mitre の CVE 辞書: CVE-2014-1959.
詳細:

Suman Jana さんが、GnuTLS が資料に書かれている挙動から外れ、 デフォルトでバージョン 1 中間証明書を CA 証明書と見なすことを報告しています。

旧安定版 (oldstable) ディストリビューション (squeeze) では X.509 バージョン 1 信頼済みCA証明書はデフォルトで許可されないためこの問題による影響はありません。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 2.12.20-8 で修正されています。

テスト版 (testing) ディストリビューション (jessie) 及び不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 2.12.23-12 で修正されています。

直ちに gnutls26 パッケージをアップグレードすることを勧めます。