Debian セキュリティ勧告

DSA-2884-1 libyaml -- セキュリティ更新

報告日時:
2014-03-26
影響を受けるパッケージ:
libyaml
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 742732.
Mitre の CVE 辞書: CVE-2014-2525.
詳細:

Google セキュリティチームの Ivan Fratric さんが LibYAML、高速な YAML 1.1 パーサ、発信ライブラリにヒープベースのバッファオーバーフロー脆弱性を発見しました。 リモートの攻撃者が特別に細工した YAML 文書を提供することが可能で、アプリケーションが libyaml を使って解析した場合にアプリケーションのクラッシュや、 潜在的にはアプリケーションを実行しているユーザの権限で任意のコードの実行を引き起こします。

旧安定版 (oldstable) ディストリビューション (squeeze) では、この問題はバージョン 0.1.3-1+deb6u4 で修正されています。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 0.1.4-2+deb7u4 で修正されています。

不安定版 (unstable) ディストリビューション (sid) ではこの問題は近く修正予定です。

直ちに libyaml パッケージをアップグレードすることを勧めます。