Рекомендация Debian по безопасности

DSA-2884-1 libyaml -- обновление безопасности

Дата сообщения:
26.03.2014
Затронутые пакеты:
libyaml
Уязвим:
Да
Ссылки на базы данных по безопасности:
В системе отслеживания ошибок Debian: Ошибка 742732.
В каталоге Mitre CVE: CVE-2014-2525.
Более подробная информация:

Айвэн Фратрик из Google Security Team обнаружил переполнение динамической памяти в LibYAML, быстрой библиотеке для грамматического разбора и генерации YAML 1.1. Удалённый атакующий может загрузить специально сформированный документ в формате YAML, который может привести к аварийному завершению работы приложения, использующего libyaml для грамматического разбора данного документа, либо потенциальному выполнению произвольного кода с привилегиями пользователя, запустившего приложение.

В предыдущем стабильном выпуске (squeeze) эта проблема была исправлена в версии 0.1.3-1+deb6u4.

В стабильном выпуске (wheezy) эта проблема была исправлена в версии 0.1.4-2+deb7u4.

В нестабильном выпуске (sid) эта проблема будет исправлена позже.

Рекомендуется обновить пакеты libyaml.