Bulletin d'alerte Debian

DSA-2890-1 libspring-java -- Mise à jour de sécurité

Date du rapport :
29 mars 2014
Paquets concernés :
libspring-java
Vulnérabilité :
Oui
Références dans la base de données de sécurité :
Dans le système de suivi des bogues Debian : Bogue 741604.
Dans le dictionnaire CVE du Mitre : CVE-2014-0054, CVE-2014-1904.
Plus de précisions :

Deux vulnérabilités ont été découvertes dans libspring-java, le paquet Debian de la plateforme Java Spring.

  • CVE-2014-0054

    Jaxb2RootElementHttpMessageConverter dans Spring MVC traite des entités XML externes.

  • CVE-2014-1904

    Spring MVC introduit une vulnérabilité de script intersite si, dans un formulaire Spring, l'action n'est pas spécifiée.

Pour la distribution stable (Wheezy), ces problèmes ont été corrigés dans la version 3.0.6.RELEASE-6+deb7u3.

Pour la distribution testing (Jessie) et la distribution unstable (Sid), ces problèmes ont été corrigés dans la version 3.0.6.RELEASE-13.

Nous vous recommandons de mettre à jour vos paquets libspring-java.