Debian Security Advisory

DSA-2926-1 linux -- security update

Date Reported:
12 May 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-0196, CVE-2014-1737, CVE-2014-1738, CVE-2014-2851, CVE-2014-3122.
More information:

Several vulnerabilities have been discovered in the Linux kernel that may lead to a denial of service, information leaks or privilege escalation:

  • CVE-2014-0196

    Jiri Slaby discovered a race condition in the pty layer, which could lead to denial of service or privilege escalation.

  • CVE-2014-1737 / CVE-2014-1738

    Matthew Daley discovered that missing input sanitising in the FDRAWCMD ioctl and an information leak could result in privilege escalation.

  • CVE-2014-2851

    Incorrect reference counting in the ping_init_sock() function allows denial of service or privilege escalation.

  • CVE-2014-3122

    Incorrect locking of memory can result in local denial of service.

For the stable distribution (wheezy), these problems have been fixed in version 3.2.57-3+deb7u1. This update also fixes a regression in the isci driver and suspend problems with certain AMD CPUs (introduced in the updated kernel from the Wheezy 7.5 point release).

For the unstable distribution (sid), these problems will be fixed soon.

We recommend that you upgrade your linux packages.