Debian Security Advisory

DSA-2959-1 chromium-browser -- security update

Date Reported:
14 Jun 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-3154, CVE-2014-3155, CVE-2014-3156, CVE-2014-3157.
More information:

Several vulnerabilities have been discovered in the chromium web browser.

  • CVE-2014-3154

    Collin Payne discovered a use-after-free issue in the filesystem API.

  • CVE-2014-3155

    James March, Daniel Sommermann, and Alan Frindell discovered several out-of-bounds read issues in the SPDY protocol implementation.

  • CVE-2014-3156

    Atte Kettunen discovered a buffer overflow issue in bitmap handling in the clipboard implementation.

  • CVE-2014-3157

    A heap-based buffer overflow issue was discovered in chromium's ffmpeg media filter.

In addition, this version corrects a regression in the previous update. Support for older i386 processors had been dropped. This functionality is now restored.

For the stable distribution (wheezy), these problems have been fixed in version 35.0.1916.153-1~deb7u1.

For the testing (jessie) and unstable (sid) distribution, these problems have been fixed in version 35.0.1916.153-1.

We recommend that you upgrade your chromium-browser packages.