Рекомендация Debian по безопасности

DSA-2969-1 libemail-address-perl -- обновление безопасности

Дата сообщения:
27.06.2014
Затронутые пакеты:
libemail-address-perl
Уязвим:
Да
Ссылки на базы данных по безопасности:
В каталоге Mitre CVE: CVE-2014-0477, CVE-2014-4720.
Более подробная информация:

Бастиан Бланк сообщил об отказе в обслуживании в Email::Address, модуле Perl для грамматического разбора и создания адресов по стандарту RFC 2822. Email::Address::parse использует значительное время на грамматический разбор пустых закавыченных строк. Удалённый злоумышленник, способный передать специально сформированный ввод приложению, использующему для грамматического разбора Email::Address, может использовать данную уязвимость для вызова отказа в обслуживании такого приложения.

В стабильном выпуске (wheezy) эта проблема была исправлена в версии 1.895-1+deb7u1.

В тестируемом выпуске (jessie) эта проблема была исправлена в версии 1.905-1.

В нестабильном выпуске (sid) эта проблема была исправлена в версии 1.905-1.

Рекомендуется обновить пакеты libemail-address-perl.