Debian Security Advisory

DSA-2976-1 eglibc -- security update

Date Reported:
10 Jul 2014
Affected Packages:
Security database references:
In Mitre's CVE dictionary: CVE-2014-0475.
More information:

Stephane Chazelas discovered that the GNU C library, glibc, processed ".." path segments in locale-related environment variables, possibly allowing attackers to circumvent intended restrictions, such as ForceCommand in OpenSSH, assuming that they can supply crafted locale settings.

For the stable distribution (wheezy), this problem has been fixed in version 2.13-38+deb7u3.

This update also includes changes previously scheduled for the next wheezy point release as version 2.13-38+deb7u2. See the Debian changelog for details.

We recommend that you upgrade your eglibc packages.