Debian セキュリティ勧告

DSA-2995-1 lzo2 -- セキュリティ更新

報告日時:
2014-08-03
影響を受けるパッケージ:
lzo2
危険性:
あり
参考セキュリティデータベース:
Debian バグ追跡システム: バグ 752861.
Mitre の CVE 辞書: CVE-2014-4607.
詳細:

Lab Mouse Security の Don A. Bailey さんが、LZOアルゴリズムで圧縮された特定のアーカイブをlzoライブラリが伸張する方法に整数オーバーフローの欠陥を発見しました。 特別に細工した、LZOで圧縮された入力を攻撃者が作成することにより、 lzoライブラリを利用したアプリケーションが伸張する際に、 アプリケーションのクラッシュや潜在的には任意のコードの実行を引き起こすことが可能です。

安定版 (stable) ディストリビューション (wheezy) では、この問題はバージョン 2.06-1+deb7u1 で修正されています。

テスト版 (testing) ディストリビューション (jessie) では、この問題はバージョン 2.08-1 で修正されています。

不安定版 (unstable) ディストリビューション (sid) では、この問題はバージョン 2.08-1 で修正されています。

直ちに lzo2 パッケージをアップグレードすることを勧めます。